اصلاح مشكلة : gradle sync failed version 3.3.0

تحدث مشكلة فشل مزامنة Gradle عند تغيير أحد إصدارات Gradle إلى إصدار أقدم وتشغيل تطبيق Android بدون أخطاء ، ولكن قد تظهر أخطاء مع إصدارات أخرى في نفس التبعيات ، وسنحل هذه المشكلة.

 

الحل

يمكنك حل مشكلة فشل مزامنة Gradle إذا كان هناك مكتبة جديدة من خدمات google لم يتم التعرف إليها ، ولذلك قم بتتبع آخر اصدار للمكتبة التي تعمل عليها ثم اعمل على تغيير الاصدار.

على سبيل المثال , لقد قمنا بتغيير الإصدار من 4.2.0 إلى 4.3.3 كما في الشيفرة التالية:

classpath 'com.google.gms:google-services:4.2.0'

بدلا من :

classpath 'com.google.gms:google-services:4.3.3'

 

المراجع

  1. ^OLDER VERSIONS OF GOOGLE PLAY SERVICES.
هل أعجبك المقال؟
 - 
Arabic
 - 
ar
Bengali
 - 
bn
German
 - 
de
English
 - 
en
French
 - 
fr
Hindi
 - 
hi
Indonesian
 - 
id
Portuguese
 - 
pt
Russian
 - 
ru
Spanish
 - 
es